Your requirements could not be resolved to an installable set of packages.

Error details:  “Your requirements could not be resolved to an installable set of packages.”

Error appearing when I try to update composer dependencies for my Laravel 5 project.

Your requirements could not be resolved to an installable set of packages

Solutions:

change

to

As Laravel has since been upgraded to 5.1.* using ~5.0 will try to grab the newer version. Just go to packagist and check versions and update to more exact versions. https://packagist.org/packages/intervention/image

Nothing worked, then I completely removed the contents of htdocs folder and did a fresh deployment from git. This worked!!!
Sam Deering is a web developer from England (currently living in Australia). In his spare time he enjoys coding, playing chess, reading and investing.

Leave a Reply

Your email address will not be published. Required fields are marked *